aur-packages/synology-drive/builds/3.0.0-12467/PKGBUILD

34 lines
1.2 KiB
Bash

# Maintainer: Felipe Martin <me@fmartingr.com>
pkgname="synology-drive"
pkgver="3.0.0"
pkgrel="12467"
pkgdesc="Drive for PC, the desktop utility of the DSM add-on package, Drive, allows you to sync and share files owned by you or shared by others between a centralized Synology NAS and multiple client computers."
arch=('i686' 'x86_64')
url="https://www.synology.com"
license=('unknown')
depends=('glibc' 'libsm' 'binutils' 'fontconfig' )
optdepends=('nautilus: For nautilus integration' )
conflicts=('cloudstation-beta' 'cloudstation-3.0' 'cloudstation-drive' )
source=()
md5sums=()
source_i686=(https://global.download.synology.com/download/Utility/SynologyDriveClient/3.0.0-12467/Ubuntu/Installer/i686/synology-drive-client-12467.i686.deb)
md5sums_i686=('0e2d5fc1e4a46932b02e71d7580d6d56')
source_x86_64=(https://global.download.synology.com/download/Utility/SynologyDriveClient/3.0.0-12467/Ubuntu/Installer/x86_64/synology-drive-client-12467.x86_64.deb)
md5sums_x86_64=('90efd017d7cb559c70ffb082bbeac864')
prepare() {
cd "$srcdir"
mkdir -p data
ar x synology-drive-*
xz -d data.tar.xz
tar xf data.tar --directory data
}
package() {
cp -r "$srcdir/data/opt" "$pkgdir/opt"
cp -r "$srcdir/data/usr" "$pkgdir/usr"
}